IndianWebPortal.com

Something Different In Linux

Home » Error and solution » Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference.

Error: Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a reference.

Solution :

This error is  occurred due the php version 5.3 and joomla is not certified to work with PHP 5.3.0.

You need to change some code in your files.

open the file
vi /home/username/public/modules/mod_mainmenu/helper.php

You can change this :
Form

function buildXML(&$params)

to

function buildXML($params)

Save the file try to access your site.

10 Responses so far.

  1. twil says:

    thanks a lot, I can resolve my problem quickly.

  2. Rolf says:

    You made my day!

  3. Simon says:

    Thanks very much for this very simple and quick fix.

  4. Alene says:

    Thank you!!! This fixed my site very easily!

  5. Sam says:

    Thanks a lot man! This worked for me. You are a genius for figuring this out. Everyone else said to downgrade my php.


Popular Posts

remove index.php fro

How to remove index.php from url in magento Ans : If you ...

PHP-Java bridge on p

  What is php-java bridge? The php-java bridge is the php ...

Set expiration for y

If you want to set the expiration to your site ...

Warning: Parameter 1

Error: Warning: Parameter 1 to modMainMenuHelper::buildXML() expected to be a ...

domain pointing to e

If you domain uses external MX record and it is ...